2010年5月31日月曜日

Microsoft UAA バス ドライバ (High Definition Audio 用) / KB888111 for Windows XP SP3

Windows XP SP3を再インストールしたあと、どうしてもオーディオドライバが導入できない。と、知り合いから嘆かれることがあります。
この現象についてネットで検索した人は大抵、UAAバスドライバがどーたらこーたら、KB888111がどーの、と口をそろえて仰るのですね。

どうやら本来SP3に組み込まれているKB888111という更新プログラムが正常に働いていない様子。
KB888111はSP1用、SP2用が単体で用意されているようですが、SP3用はSP3に元々入っているはずなので提供されていません。

で、強制的にSP2用KB888111をSP3に導入するためのバッチファイルを作りました。

Windows XP SP3用KB888111導入バッチファイル ダウンロード

他にも導入方法はいくつかあって始めのうちは毎回時間をかけて説明していたのですが、すっかり面倒になって最近はいつもこれを渡して「setup.batを実行してみて」と言って終わりにしています。

それにしても、XPは何百回とインストールしてますが、自分自身はこの現象を見たこと無いんですよね…。

あ、あと、UAAバスドライバが導入されているにも関わらずXP起動時にUAAバスドライバが無い旨のメッセージ(新しいハードウェアの検索ウィザード)が出てしまう現象についてもたまーーに聞きますが、これも直るかもしれません。(hdaudbusフォルダ内のinfファイルを手動適用すれば確実です。)

で、提供しておいてなんですが、自己責任の下でご利用くださいね、と。


稚拙なバッチファイルについてはご勘弁を。まぁ、解決できればそれでよいではないですか。
システムがXP SP3環境かチェックした上で、一時的にシステムがSP2であると見せかけて強制実行しています。

---
When "Microsoft UAA Bus Driver for High Definition Audio - KB888111" can't be installed under Windows XP SP3, try to download and use this.

31 件のコメント:

  1. おかげで音が鳴りました。
    ありがとうございました!!

    返信削除
  2. >匿名さん
    わざわざご報告ありがとうございます!
    やー、よかったよかった。

    返信削除
  3. やっとうざい検出から逃れることができました・・
    こんなん作れるってすごい!ありがとうございます!

    返信削除
  4. 他にも方法を検索して見つけましたがかなりめんどくさそうだったので本当に助かりました。

    返信削除
  5. >匿名さんと匿名さん
    ブログの存在を忘れがちなため返信が遅くなりましたが、お役に立てたようで嬉しいです(´∀`)

    返信削除
  6. グラフィックカードを交換したら、UAAバスドライバが導入されているにも関わらずXP起動時にUAAバスドライバが無い旨のメッセージが出るようになりました。デバイスは?マークはないのです。うざいのでいろいろやってみましたが×、バッチファイルをためしたらメッセージが出なくなりました。ありがとうございました。

    返信削除
  7. 私もグラボを交換した後に起こったので助かりました。↑の方同様、別にデバイスが機能していなかったわけではないので問題は無かったのですが、うざい事この上なかったのでバッチの方使わせていただきました。ありがとうございます。

    返信削除
  8. >匿名さんと匿名さん
    グラフィックカードの交換でも起こるのですね…。
    HDMIオーディオは見かけのデバイス名は一緒でもGPU世代によって仕様が違うので、その辺の絡みでしょうか。
    どちらにしても改善したのは嬉しいことです。ご報告ありがとうございました。

    返信削除
  9. こんばんははじめまして、今日パソコンのCPUとメモリとグラボを、初心者ながら四苦八苦して交換したら以前は出なかった、バスドライバーが云々っていうのが出るようになってしまい困って検索したところ、ここにたどり着き導入パッチを使わせていただいたところ表示が出なくなりました。
    本当にありがとうございました

    返信削除
  10. 初めまして。
    私もグラボを交換した際に↑の方々と同様のメッセージが出るようになり、困っていました。
    ネットでの検索でここに流れ着き、おかげさまで問題が解決できました。

    本当に助かりました。ありがとうございました。

    返信削除
  11. >匿名さんs
    まだまだXPで苦労されている方はいらっしゃるのですね。お役に立てて良かったです。

    返信削除
  12. XP SP3を再インストールしたら、初めてRealtekのドライバがインストール出来ない症状に遭遇しまして

    こちらのバッチファイルを使用させて頂いたら、一発で直りました。
    非常に助かりました。
    ありがとうございました。

    返信削除
  13. >匿名さん
    お役に立ててなによりです。
    この問題の再現条件ってなんなんでしょうかねー。

    返信削除
  14. こんにちわ、ヤフオクで買ったマザーにXPSP3入れたら音が出なくて、セーフモードでドライバ削除したり、ここのバッチファイル使わせてもらい直りました。マザーはASUSのM4A88TD-V EVO/USB3です。ありがとうございました。

    返信削除
  15. 前日午前3時までスピーカーから音が出ていたのに、今朝PCの電源を入れたら、無音状態でした。
    ネットで検索し、こちらのサイトに行き着きまして、バッチファイルを使わせて頂いたら、一発解決でした。
    ソフトのインストールとかハードの変更・追加など何もしていないの……。突然音が出なくなって焦りましたが、解決出来て助かりました。ありがとうございました。

    返信削除
  16. ユーザー名・パスワードとは一体…

    返信削除
  17. サーバメンテナンス中です。すいません…。
    以下からどうぞ。

    https://rapidshare.com/files/1859814316/kb888111_sp3.zip

    返信削除
  18. 突然PCの音が出なくなり、やっとこのページにいきつきました。上記の「以下からどうぞ」のページを開いたのですが、パスワードを入れないとダウンロードできないようで・・・申し訳ないのですがバッチファイルのダウンロードの仕方を教えてください

    返信削除
  19. ありがとうございました。やっと音が出るようになりました!
    本当に助かりました。

    返信削除
  20. XP SP3使用です。 Sound Maxを誤って削除してしまい、再インストール使用としたらHD Audio バスドライバーが無いとの事でそれをインストールしようとして出来ずにこちらに辿り着きました。 パッチをダウンロードさせていただいたのですが?マークの付いたマルチメディアコントローラーのドライバー更新をしようとするのですが出来ないのです。 何がたらないのでしょうか?  よろしくご指導くださいますよう お願いします。

    返信削除
  21. >M Sugiharaさん
    デバイスマネージャに"?マルチメディアコントローラ"と表示されているのであれば、すでにバスドライバはインストールできている可能性が高いです。

    デバイスマネージャ>システムデバイス内に下記のどちらかがあれば、当サイトはすでに用無しでしょう。

    ・Microsoft UAA Bus Driver for High Definition Audio
    ・Microsoft UAA バス ドライバ (High Definition Audio 用)

    あとはSoundMaxドライバをインストールするだけです。問題が改善しないのであれば、何か別の要因かもしれませんね。

    ちなみに、バスドライバがインストールできていない状況ではまだSoundMaxをオーディオデバイスとは認識できないため、デバイスマネージャに"?PCIデバイス"か"?PCI Device"と表示されたと記憶しています。

    頑張ってください!

    それにしてもSoundMaxって懐かしいですね。Conexantに買収された後、どうなったんだろう…。

    返信削除
  22. 私もグラボを交換したら、上記の方々と同様のメッセージが出て困っておりましたが、解決出来ました。
    本当にありがとうございました。

    返信削除
  23. 音が出ましたありがとうございます^^

    しかし、Media Player、ゴムプレイヤーなど起動すると、
    元に戻り音が出なくなります^^;

    なぜでしょうか;;

    返信削除
  24. >匿名さん
    元に戻るというのは、デバイスマネージャ上でドライバが未適用の状態に戻るデバイスがあるということでしょうか。
    そうでなければ、単にゴムプレーヤーなりのアプリケーションが既定のオーディオデバイスとは違うデバイスを使用しているか、既定のオーディオデバイスを変更してしまっているか…。
    判断が難しければ、今使用していないオーディオデバイスをデバイスマネージャ上で全部無効にしてみるというのは試す勝ちありそうな気がします。

    返信削除
  25. >>Halbappie様
    早速のご返答ありがとうございます。


    使用デバイスはデバイスマネージャーで確認した所、High Definition Audio(UAA)のみでした。。
    ベンダIDを調べた所1106で、VIAのものらしいのですが・・

    症状を詳しく書きますと、パッチ適応後、効果音、youtubeなどの音は出るのですが、Media Player、ゴムプレイヤーなどを起動すると、音がまったく出なくなり、効果音、youtubeの音さえでなくなるしだいです。デバイスマネジャーで確認しますと、(正常に動作しています)とでます。もちろん有効になっていまです。


    何が原因かお分かりになりますでしょうか?

    返信削除
  26. >匿名さん

    ドライバかOSになにか問題があるかもしれませんね。
    UAAバスドライバを入れると一時的に音の出るようになるのは、オーディオデバイスがその時に初期化されるからだと思います。そもそもUAAバスドライバがインストールできない、という問題とは違うものと思います。
    とりあえず一旦サウンドドライバとUAAバスドライバを両者とも削除して、サウンドドライバを再導入してみるってところかと思いますが、実際に触らないとなんともわからないです。すいません…。

    返信削除
  27. >>Halbappie様

    いえいえとんでもないです。

    実際触らないと・・というのはごもっともです。
    まずは助言通りの操作してみたいと思います。
    ご丁寧にお答えして頂きありがとうございます^^


    返信削除
  28. OS:XPSP3でASUAの88GTが壊れた為、諸データ等の事がありとりあえずXP環境で復活させるため、安売りのGIGABYTEのGT610に交換後、Microsoft UAA Busのトラブルに巻き込まれておまりましたところ、当サイトさまのおかげでエラッタエラー表示から開放されました。
    本当にありがとうございました。

    返信削除
  29. XPが不調になりSP3を再インストールしたら音は鳴らないしUAA Busが出て困ってました。世の中はWindows8なんですが、仕事用はXPのほうが慣れてて変えたくなかったので本当に助かりました。ありがとうございます。

    返信削除
  30. 助かりました。ありがとうございました。

    返信削除
  31. SoundMaxを削除してしまってから音が出ず、ドライバも入らなくなって困り果てていましたが、こちらで公開されているバッチを当ててからもう一度ドライバ更新を試してみると無事ドライバが入って音も出るようになりました。
    本当に有難う御座いました。

    返信削除